Calibre starting problem

If you get the error while launching Calibre

Traceback (most recent call last):
File "/usr/bin/calibre", line 8, in
load_entry_point('calibre==0.6.5', 'gui_scripts', 'calibre')()
File "/usr/lib64/python2.6/site-packages/calibre/gui2/main.py", line 1896, in main
return run_gui(opts, args, actions, listener, app)
File "/usr/lib64/python2.6/site-packages/calibre/gui2/main.py", line 1804, in run_gui
wizard().exec_()
File "/usr/lib64/python2.6/site-packages/calibre/gui2/wizard/__init__.py", line 554, in wizard
w = Wizard(parent)
File "/usr/lib64/python2.6/site-packages/calibre/gui2/wizard/__init__.py", line 520, in __init__
self.kindle_page = KindlePage()
File "/usr/lib64/python2.6/site-packages/calibre/gui2/wizard/__init__.py", line 201, in __init__
self.setupUi(self)
File "/usr/lib64/python2.6/site-packages/calibre/gui2/wizard/kindle_ui.py", line 30, in setupUi
self.send_email_widget = SendEmail(WizardPage)
File "/usr/lib64/python2.6/site-packages/calibre/gui2/wizard/send_email.py", line 52, in __init__
self.setupUi(self)
File "/usr/lib64/python2.6/site-packages/calibre/gui2/wizard/send_email_ui.py", line 49, in setupUi
self.relay_port.setProperty("value", 25)
TypeError: argument 2 of QObject.setProperty() has an invalid type 


The solution is pretty simple, Upgrade python-qt4 to greater than 4.6.1

1 comments:

Kalidasu said...

I felt this will be helpful, as I found only one link to solve this problem.

Post a Comment